Server

ID #1119

Vista-Client an Samba anmelden

Frage: was muss ich tun, damit auch ein Vista-Client sich anmelden kann?

Antwort1: Ich hab unter HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa im Schlüssel LmCompatibilityLevel den Wert von 3 auf 1 geändert. Jetzt klappt's auch wieder mit älteren Samba-Versionen. :-)

Antwort 2: Vista nutzt eine neuen Version des SMB Protokolls. Soll sicherer sein, einziges Problem war nur, dass Samba dieses nicht unterstützt. Und da mein WL700g auf einem Linux läuft und Samba für die Shares nutzt, kann es nicht funktionieren.Um das Problem zu beheben, muss man die Lokalen Sicherheitsrichtlinien bearbeiten. Erstmal den Richtlinieneditor über Start -> Eingabeleiste -> secpol.msc starten und dann folgenden Pfad hinunter hangeln. Lokale Richtlinien -> Sicherheitsoptionen Dort findet ihr dann auf der rechten Seite einen Punkt der Netzwerksicherheit: LAN-Manager-Authentifizierungsebene   heisst. Dort ein Doppelklick und die Option LM-und NTLM-Antworten senden (NTLMv2-Sitzungssicherheit verwenden) auswählen. Dann nur noch auf Ok klicken und den Editor wieder schliessen. Nun sollte es wieder möglich sein, Samba-Shares zu öffnen und zu verbinden. Falls nicht sollte noch ein Neustart gemacht werden. Bei mir hat es zwar ohne funktioniert, aber bei Windows kann man ja nie wissen.

Antwort 3: to make sure samba ver. 3+ will authenticate normally with vista:(my build: windows vista ultimate)-(linux) add this parameter to your smb.conf client ntlmv2 auth = yes (linux) restart samba (vista) map the share to a drive no need to edit secpol.msc Paolo, http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746 Beitrag Nr. 84

Antwort 4: Folgende Schritte haben den Erfolg gebracht:

1. Registry-Patches von Gee-Seiten einspielen: WinXP_SignOrSeal.reg:REGEDIT4HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\netlogon\parameters"RequireSignOrSeal"=dword:00000000Winxp-PlainPassword.reg:REGEDIT4[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkStation\Parameters]"EnablePlainTextPassword"=dword:00000001

2. Ausführen "secpol.msc": -> Lokale Richtlinien ->Sicherheitsoptionen hier:Netzwerksicherheit: Lan-Manager-Authentifizierungsebene auf "LM- und NTLM-Antworten senden (NTLMv2-Sitzungssicherheit verwenden)" setzenSoweit habe ich das auch an verschiedener Stelle dokumentiert gefunden, geholfen alleine hat es in meinem Falle allerdings nicht. Erst nach dem nächsten Punkt war der gewünschte Erfolg da:

3. Ausführen "secpol.msc" -> Lokale Richtlinien ->Sicherheitsoptionen hier: Domänenmitglied: Daten des sicheren Kanals digital verschlüsseln oder signieren (immer) auf "deaktiviert" stellen

Darauf hatte ich nirgends einen Hinweis gefunden, ich habe mir die einzelnen Punkte der "secpol.msc" aber einmal ganz genau angeschaut, und der kam mir dabei verdächtig vor.Ich weiß jetzt nicht, ob die Punkte 1 und 2 wirklich notwendig waren, ist mir auch egal, ich muss nicht alles wissen. Wenn es mit diesen 3 Schritten beim nächsten Mal wieder klappt, ist es mir den Aufwand nicht wert, herauszufinden, was ich weglassen könnte.

Peter Schmitt, GEE-Mailingliste 7. Juni 2008

Links: http://www.3dwin.net/archive/index.php/t-50683.html

http://bauer-martin.com/node/77 http://www.bit-bloc.de/archives/4

Tags: Samba, Vista

Verwandte Artikel:

Letzte Änderung der FAQ: 2011-04-06 16:02
Autor: malvis
Revision: 1.1

Sprache ändern
 

Digg it! Share on Facebook FAQ ausdrucken FAQ weiterempfehlen Als PDF-Datei anzeigen
Übersetzungsvorschlag für Übersetzungsvorschlag für
Bewertung der Nützlichkeit dieser FAQ:

Durchschnittliche Bewertung: 3.91 (11 Abstimmungen)

vollkommen überflüssig 1 2 3 4 5 sehr wertvoll

Kommentieren nicht möglich